In short
- CVE-2018-7753 is a CRITICAL (CVSS 9.8) vulnerability affecting bleach, bleach (mozilla).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.4% of all vulnerabilities.
- Fix: update to 2.1.3 or later.
| Package | Affected versions | Patched versions |
|---|
| bleach PyPI | ≥ 2.1, < 2.1.3≥ 2.1.0, < 2.1.3
| 2.1.3
|
| bleach | = 2.1= 2.1.1= 2.1.2
| No fix yet |
Description
An issue was discovered in Bleach 2.1.x before 2.1.3. Attributes that have URI values weren't properly sanitized if the values contained character entities. Using character entities, it was possible to construct a URI value with a scheme that was not allowed that would slide through unsanitized.
NVD description
An issue was discovered in Bleach 2.1.x before 2.1.3. Attributes that have URI values weren't properly sanitized if the values contained character entities. Using character entities, it was possible to construct a URI value with a scheme that was not allowed that would slide through unsanitized.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free