In short
- CVE-2018-8015 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.orc:orc, orc (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.2%, higher than 88.3% of all vulnerabilities.
- Fix: update to 1.4.4 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.orc:orc Maven | ≥ 1.0.0, < 1.4.4
| 1.4.4
|
| orc | > 1.0.0, ≤ 1.4.3
| No fix yet |
Description
In Apache ORC 1.0.0 to 1.4.3 a malformed ORC file can trigger an endlessly recursive function call in the C++ or Java parser. The impact of this bug is most likely denial-of-service against software that uses the ORC file parser. With the C++ parser, the stack overflow might possibly corrupt the stack.
NVD description
In Apache ORC 1.0.0 to 1.4.3 a malformed ORC file can trigger an endlessly recursive function call in the C++ or Java parser. The impact of this bug is most likely denial-of-service against software that uses the ORC file parser. With the C++ parser, the stack overflow might possibly corrupt the stack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free