In short
- CVE-2018-8026 is a MEDIUM (CVSS 5.5) vulnerability affecting org.apache.solr:solr-core, solr (apache).
- Chance of exploitation in the next 30 days (EPSS): 9.0%, higher than 95.3% of all vulnerabilities.
- Fix: update to 6.6.5, 7.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.solr:solr-core Maven | ≥ 6.0.0, < 6.6.5≥ 7.0.0, < 7.4.0
| 6.6.57.4.0
|
| solr | ≥ 7.0.0, ≤ 7.3.1> 6.0.0, ≤ 6.6.4
| No fix yet |
Description
This vulnerability in Apache Solr 6.0.0 to 6.6.4 and 7.0.0 to 7.3.1 relates to an XML external entity expansion (XXE) in Solr config files (currency.xml, enumsConfig.xml referred from schema.xml, TIKA parsecontext config file). In addition, Xinclude functionality provided in these config files is also affected in a similar way. The vulnerability can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network. The manipulated files can be uploaded as configsets using Solr's API, allowing to exploit that vulnerability.
NVD description
This vulnerability in Apache Solr 6.0.0 to 6.6.4 and 7.0.0 to 7.3.1 relates to an XML external entity expansion (XXE) in Solr config files (currency.xml, enumsConfig.xml referred from schema.xml, TIKA parsecontext config file). In addition, Xinclude functionality provided in these config files is also affected in a similar way. The vulnerability can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network. The manipulated files can be uploaded as configsets using Solr's API, allowing to exploit that vulnerability.
More vulnerabilities in org.apache.solr:solr-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free