In short
- CVE-2018-8036 is a MEDIUM (CVSS 6.5) vulnerability affecting org.apache.pdfbox:pdfbox, pdfbox (apache).
- Chance of exploitation in the next 30 days (EPSS): 4.0%, higher than 90.5% of all vulnerabilities.
- Fix: update to 1.8.15, 2.0.11 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.pdfbox:pdfbox Maven | ≥ 1.8.0, < 1.8.15≥ 2.0.0RC1, < 2.0.11
| 1.8.152.0.11
|
| pdfbox | = 2.0.0≥ 2.0.0, ≤ 2.0.10> 1.8.0, ≤ 1.8.14
| No fix yet |
Description
In Apache PDFBox 1.8.0 to 1.8.14 and 2.0.0RC1 to 2.0.10, a carefully crafted (or fuzzed) file can trigger an infinite loop which leads to an out of memory exception in Apache PDFBox's AFMParser.
NVD description
In Apache PDFBox 1.8.0 to 1.8.14 and 2.0.0RC1 to 2.0.10, a carefully crafted (or fuzzed) file can trigger an infinite loop which leads to an out of memory exception in Apache PDFBox's AFMParser.
More vulnerabilities in org.apache.pdfbox:pdfbox
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free