In short
- CVE-2018-8048 is a MEDIUM (CVSS 6.1) vulnerability affecting loofah, nokogiri, loofah (loofah project).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 80.0% of all vulnerabilities.
- Fix: update to 2.2.1, 1.8.3 or later.
| Package | Affected versions | Patched versions |
|---|
| loofah RubyGems | < 2.2.1
| 2.2.1
|
| nokogiri RubyGems | < 1.8.3
| 1.8.3
|
| loofah | < 2.2.1
| 2.2.1
|
Description
Loofah allows non-whitelisted attributes to be present in sanitized output when input with specially-crafted HTML fragments.
Users are affected if running Loofah < 2.2.1, but only:
- when running on MRI or RBX,
- in combination with libxml2 >= 2.9.2.
JRuby users are not affected.
NVD description
In the Loofah gem through 2.2.0 for Ruby, non-whitelisted HTML attributes may occur in sanitized output by republishing a crafted HTML fragment.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free