In short
- CVE-2018-8768 is a HIGH (CVSS 7.8) vulnerability affecting notebook, notebook (jupyter).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.0% of all vulnerabilities.
- Fix: update to 5.4.1 or later.
| Package | Affected versions | Patched versions |
|---|
| notebook PyPI | < 5.4.1
| 5.4.1
|
| notebook | < 5.4.1
| 5.4.1
|
Description
In Jupyter Notebook before 5.4.1, a maliciously forged notebook file can bypass sanitization to execute JavaScript in the notebook context. Specifically, invalid HTML is 'fixed' by jQuery after sanitization, making it dangerous.
NVD description
In Jupyter Notebook before 5.4.1, a maliciously forged notebook file can bypass sanitization to execute JavaScript in the notebook context. Specifically, invalid HTML is 'fixed' by jQuery after sanitization, making it dangerous.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free