| Package | Affected versions | Patched versions |
|---|---|---|
| gitlab | ≥ 10.5.0, < 10.5.7≥ 10.6.0, < 10.6.3≥ 8.4, < 10.4.7 | 10.5.710.6.310.4.7 |
GitLab Community and Enterprise Editions version 8.4 up to 10.4 are vulnerable to XSS because a lack of input validation in the merge request component leads to cross site scripting (specifically, filenames in changes tabs of merge requests). This is fixed in 10.6.3, 10.5.7, and 10.4.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free