In short
- CVE-2019-0187 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.jmeter:ApacheJMeter, jmeter (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.6%, higher than 85.6% of all vulnerabilities.
- Fix: update to 5.1 or later.
Description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
NVD description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
More vulnerabilities in org.apache.jmeter:ApacheJMeter
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free