In short
- CVE-2019-0212 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.hbase:hbase, hbase (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.8%, higher than 90.0% of all vulnerabilities.
- Fix: update to 2.0.5, 2.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.hbase:hbase Maven | ≥ 2.0.0, < 2.0.5≥ 2.1.0, < 2.1.4
| 2.0.52.1.4
|
| hbase | ≥ 2.0.0, ≤ 2.0.4≥ 2.1.0, ≤ 2.1.3
| No fix yet |
Description
In all previously released Apache HBase 2.x versions (2.0.0-2.0.4, 2.1.0-2.1.3), authorization was incorrectly applied to users of the HBase REST server. Requests sent to the HBase REST server were executed with the permissions of the REST server itself, not with the permissions of the end-user. This issue is only relevant when HBase is configured with Kerberos authentication, HBase authorization is enabled, and the REST server is configured with SPNEGO authentication. This issue does not extend beyond the HBase REST server.
NVD description
In all previously released Apache HBase 2.x versions (2.0.0-2.0.4, 2.1.0-2.1.3), authorization was incorrectly applied to users of the HBase REST server. Requests sent to the HBase REST server were executed with the permissions of the REST server itself, not with the permissions of the end-user. This issue is only relevant when HBase is configured with Kerberos authentication, HBase authorization is enabled, and the REST server is configured with SPNEGO authentication. This issue does not extend beyond the HBase REST server.
More vulnerabilities in org.apache.hbase:hbase
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free