In short
- CVE-2019-0542 is a HIGH (CVSS 8.8) vulnerability affecting openshift container platform (redhat), xterm.js (xtermjs), xterm.
- Chance of exploitation in the next 30 days (EPSS): 3.2%, higher than 88.0% of all vulnerabilities.
- Fix: update to 3.10.163, 3.9.99, 3.11.104, 5.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| openshift container platform | ≥ 3.10, < 3.10.163≥ 3.9, < 3.9.99> 3.11, < 3.11.104
| 3.10.1633.9.993.11.104
|
| xterm.js | < 5.0.0
| 5.0.0
|
| xterm npm | ≥ 3.10.0, < 3.10.1≥ 3.9.0, < 3.9.2< 3.8.1
| 3.10.13.9.23.8.1
|
Description
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters.
NVD description
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution Vulnerability." This affects xterm.js.
More vulnerabilities in openshift container platform
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free