In short
- CVE-2019-1000008 is a MEDIUM (CVSS 6.5) vulnerability affecting helm.sh/helm, helm (helm).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.0% of all vulnerabilities.
- Fix: update to 2.12.2, 2.12.2+incompatible or later.
| Package | Affected versions | Patched versions |
|---|
| helm.sh/helm Go | ≥ 2.0.0, < 2.12.2≥ 2.0.0+incompatible, < 2.12.2+incompatible
| 2.12.22.12.2+incompatible
|
| helm | ≥ 2.0.0, < 2.12.2
| 2.12.2
|
Description
All versions of Helm between Helm >=2.0.0 and < 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in The commands helm fetch --untar and helm lint some.tgz that can result when chart archive files are unpacked a file may be unpacked outside of the target directory. This attack appears to be exploitable via a victim must run a helm command on a specially crafted chart archive. This vulnerability appears to have been fixed in 2.12.2.
NVD description
All versions of Helm between Helm >=2.0.0 and < 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in The commands `helm fetch --untar` and `helm lint some.tgz` that can result when chart archive files are unpacked a file may be unpacked outside of the target directory. This attack appears to be exploitable via a victim must run a helm command on a specially crafted chart archive. This vulnerability appears to have been fixed in 2.12.2.
More vulnerabilities in helm.sh/helm
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free