In short
- CVE-2019-1003027 is a MEDIUM (CVSS 4.3) vulnerability affecting hudson.plugins.octopusdeploy:octopusdeploy, octopusdeploy (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 64.0% of all vulnerabilities.
- Fix: update to 1.9.0 or later.
Description
A server-side request forgery vulnerability exists in Jenkins OctopusDeploy Plugin 1.8.1 and earlier in OctopusDeployPlugin.java that allows attackers with Overall/Read permission to have Jenkins connect to an attacker-specified URL and obtain the HTTP response code if successful, and exception error message otherwise.
NVD description
A server-side request forgery vulnerability exists in Jenkins OctopusDeploy Plugin 1.8.1 and earlier in OctopusDeployPlugin.java that allows attackers with Overall/Read permission to have Jenkins connect to an attacker-specified URL and obtain the HTTP response code if successful, and exception error message otherwise.
More vulnerabilities in hudson.plugins.octopusdeploy:octopusdeploy
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free