In short
- CVE-2019-1010306 is a CRITICAL (CVSS 9.8) vulnerability affecting slanger, slanger (teller).
- Chance of exploitation in the next 30 days (EPSS): 4.0%, higher than 90.7% of all vulnerabilities.
- Fix: update to 0.6.1 or later.
| Package | Affected versions | Patched versions |
|---|
| slanger RubyGems | < 0.6.1
| 0.6.1
|
| slanger | = 0.6.0
| No fix yet |
Description
Slanger 0.6.0 is affected by Remote Code Execution (RCE). The impact is A remote attacker can execute arbitrary commands by sending a crafted request to the server. The component is Message handler & request validator. The attack vector is Remote unauthenticated. The fixed version is after commit 5267b455caeb2e055cccf0d2b6a22727c111f5c3.
NVD description
Slanger 0.6.0 is affected by: Remote Code Execution (RCE). The impact is: A remote attacker can execute arbitrary commands by sending a crafted request to the server. The component is: Message handler & request validator. The attack vector is: Remote unauthenticated. The fixed version is: after commit 5267b455caeb2e055cccf0d2b6a22727c111f5c3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free