In short
- CVE-2019-10217 is a MEDIUM (CVSS 6.5) vulnerability affecting ansible, ansible (redhat).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.3% of all vulnerabilities.
- Fix: update to 2.8.4 or later.
| Package | Affected versions | Patched versions |
|---|
| ansible PyPI | ≥ 2.8.0, < 2.8.4≥ 2.8.0a1, < 2.8.4
| 2.8.4
|
| ansible | ≥ 2.8.0, < 2.8.4
| 2.8.4
|
Description
A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.
NVD description
A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free