In short
- CVE-2019-10289 is a MEDIUM (CVSS 6.5) vulnerability affecting org.jenkins-ci.plugins:netsparker-cloud-scan, netsparker cloud scan (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.4% of all vulnerabilities.
- Fix: update to 1.1.6 or later.
Description
A cross-site request forgery vulnerability in Jenkins Netsparker Cloud Scan Plugin 1.1.5 and older in the NCScanBuilder.DescriptorImpl#doValidateAPI form validation method allowed attackers to initiate a connection to an attacker-specified server.
NVD description
A cross-site request forgery vulnerability in Jenkins Netsparker Cloud Scan Plugin 1.1.5 and older in the NCScanBuilder.DescriptorImpl#doValidateAPI form validation method allowed attackers to initiate a connection to an attacker-specified server.
More vulnerabilities in org.jenkins-ci.plugins:netsparker-cloud-scan
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free