In short
- CVE-2019-10312 is a MEDIUM (CVSS 4.3) vulnerability affecting org.jenkins-ci.plugins:ansible-tower, ansible tower (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.3% of all vulnerabilities.
- Fix: update to 0.9.2 or later.
Description
A missing permission check in Jenkins Ansible Tower Plugin 0.9.1 and earlier in the TowerInstallation.TowerInstallationDescriptor#doFillTowerCredentialsIdItems method allowed attackers with Overall/Read permission to enumerate credentials ID of credentials stored in Jenkins.
NVD description
A missing permission check in Jenkins Ansible Tower Plugin 0.9.1 and earlier in the TowerInstallation.TowerInstallationDescriptor#doFillTowerCredentialsIdItems method allowed attackers with Overall/Read permission to enumerate credentials ID of credentials stored in Jenkins.
More vulnerabilities in org.jenkins-ci.plugins:ansible-tower
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free