In short
- CVE-2019-10320 is a MEDIUM (CVSS 4.3) vulnerability affecting org.jenkins-ci.plugins:credentials, credentials (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 61.9% of all vulnerabilities.
- Fix: update to 2.1.19 or later.
Description
Jenkins Credentials Plugin 2.1.18 and earlier allowed users with permission to create or update credentials to confirm the existence of files on the Jenkins master with an attacker-specified path, and obtain the certificate content of files containing a PKCS#12 certificate.
NVD description
Jenkins Credentials Plugin 2.1.18 and earlier allowed users with permission to create or update credentials to confirm the existence of files on the Jenkins master with an attacker-specified path, and obtain the certificate content of files containing a PKCS#12 certificate.
More vulnerabilities in org.jenkins-ci.plugins:credentials
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free