In short
- CVE-2019-10330 is a HIGH (CVSS 7.5) vulnerability affecting org.jenkins-ci.plugins:gitea, gitea (gitea).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 82.0% of all vulnerabilities.
- Fix: update to 1.1.2 or later.
Description
Jenkins Gitea Plugin prior to 1.1.2 did not implement trusted revisions, allowing attackers without commit access to the Git repo to change Jenkinsfiles even if Jenkins is configured to consider them to be untrusted.
NVD description
Jenkins Gitea Plugin 1.1.1 and earlier did not implement trusted revisions, allowing attackers without commit access to the Git repo to change Jenkinsfiles even if Jenkins is configured to consider them to be untrusted.
More vulnerabilities in org.jenkins-ci.plugins:gitea
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free