In short
- CVE-2019-10340 is a HIGH (CVSS 8.8) vulnerability affecting io.jenkins.docker:docker-plugin, docker (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.5% of all vulnerabilities.
- Fix: update to 1.1.7 or later.
Description
A cross-site request forgery vulnerability in Jenkins Docker Plugin 1.1.6 and earlier in DockerAPI.DescriptorImpl#doTestConnection allowed users with Overall/Read access to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
NVD description
A cross-site request forgery vulnerability in Jenkins Docker Plugin 1.1.6 and earlier in DockerAPI.DescriptorImpl#doTestConnection allowed users with Overall/Read access to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
More vulnerabilities in io.jenkins.docker:docker-plugin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free