In short
- CVE-2019-10362 is a MEDIUM (CVSS 5.4) vulnerability affecting io.jenkins:configuration-as-code, configuration as code (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.74%, higher than 54.6% of all vulnerabilities.
- Fix: update to 1.25 or later.
Description
Jenkins Configuration as Code Plugin 1.24 and earlier did not escape values resulting in variable interpolation during configuration import when exporting, allowing attackers with permission to change Jenkins system configuration to obtain the values of environment variables.
NVD description
Jenkins Configuration as Code Plugin 1.24 and earlier did not escape values resulting in variable interpolation during configuration import when exporting, allowing attackers with permission to change Jenkins system configuration to obtain the values of environment variables.
More vulnerabilities in io.jenkins:configuration-as-code
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free