In short
- CVE-2019-10371 is a HIGH (CVSS 7.5) vulnerability affecting org.jenkins-ci.plugins:gitlab-oauth, gitlab oauth (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.6% of all vulnerabilities.
- Fix: update to 1.5 or later.
Description
A session fixation vulnerability in Jenkins Gitlab Authentication Plugin 1.4 and earlier in GitLabSecurityRealm.java allows unauthorized attackers to impersonate another user if they can control the pre-authentication session.
NVD description
A session fixation vulnerability in Jenkins Gitlab Authentication Plugin 1.4 and earlier in GitLabSecurityRealm.java allows unauthorized attackers to impersonate another user if they can control the pre-authentication session.
More vulnerabilities in org.jenkins-ci.plugins:gitlab-oauth
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free