In short
- CVE-2019-10394 is a MEDIUM (CVSS 4.2) vulnerability affecting org.jenkins-ci.plugins:script-security, script security (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 64.0% of all vulnerabilities.
- Fix: update to 1.63 or later.
Description
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.62 and earlier related to the handling of property names in property expressions on the left-hand side of assignment expressions allowed attackers to execute arbitrary code in sandboxed scripts.
NVD description
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.62 and earlier related to the handling of property names in property expressions on the left-hand side of assignment expressions allowed attackers to execute arbitrary code in sandboxed scripts.
More vulnerabilities in org.jenkins-ci.plugins:script-security
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free