In short
- CVE-2019-10431 is a CRITICAL (CVSS 9.9) vulnerability affecting org.jenkins-ci.plugins:script-security, script security (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.2% of all vulnerabilities.
- Fix: update to 1.65 or later.
Description
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.64 and earlier related to the handling of default parameter expressions in constructors allowed attackers to execute arbitrary code in sandboxed scripts.
NVD description
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.64 and earlier related to the handling of default parameter expressions in constructors allowed attackers to execute arbitrary code in sandboxed scripts.
More vulnerabilities in org.jenkins-ci.plugins:script-security
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free