In short
- CVE-2019-10761 is a HIGH (CVSS 8.3) vulnerability affecting vm2 (vm2 project), vm2.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.0% of all vulnerabilities.
- Fix: update to 3.6.11 or later.
| Package | Affected versions | Patched versions |
|---|
| vm2 | < 3.6.11
| 3.6.11
|
| vm2 npm | < 3.6.11
| 3.6.11
|
Description
This affects the package vm2 before 3.6.11. It is possible to trigger a RangeError exception from the host rather than the "sandboxed" context by reaching the stack call limit with an infinite recursion. The returned object is then used to reference the mainModule property of the host code running the script allowing it to spawn a child_process and execute arbitrary code.
NVD description
This affects the package vm2 before 3.6.11. It is possible to trigger a RangeError exception from the host rather than the "sandboxed" context by reaching the stack call limit with an infinite recursion. The returned object is then used to reference the mainModule property of the host code running the script allowing it to spawn a child_process and execute arbitrary code.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free