In short
- CVE-2019-10806 is a MEDIUM (CVSS 4.3) vulnerability affecting vega (vega project), vega-util.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.9% of all vulnerabilities.
- Fix: update to 1.13.1 or later.
| Package | Affected versions | Patched versions |
|---|
| vega | < 1.13.1
| 1.13.1
|
| vega-util npm | < 1.13.1
| 1.13.1
|
Description
vega-util prior to 1.13.1 allows manipulation of object prototype. The 'vega.mergeConfig' method within vega-util could be tricked into adding or modifying properties of the Object.prototype.
NVD description
vega-util prior to 1.13.1 allows manipulation of object prototype. The 'vega.mergeConfig' method within vega-util could be tricked into adding or modifying properties of the Object.prototype.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free