In short
- CVE-2019-12274 is a HIGH (CVSS 8.8) vulnerability affecting github.com/rancher/rancher, rancher (suse).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.2% of all vulnerabilities.
- Fix: update to 2.2.4, 2.2.4+incompatible, 1.6.27 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/rancher/rancher Go | ≥ 2.0.0, < 2.2.4≥ 2.0.0+incompatible, < 2.2.4+incompatible< 1.6.27
| 2.2.42.2.4+incompatible1.6.27
|
| rancher | ≥ 1.0.0, ≤ 1.6.28≥ 2.0.0, ≤ 2.2.3
| No fix yet |
Description
In Rancher 1 and 2 through 2.2.3, unprivileged users (if allowed to deploy nodes) can gain admin access to the Rancher management plane because node driver options intentionally allow posting certain data to the cloud. The problem is that a user could choose to post a sensitive file such as /root/.kube/config or /var/lib/rancher/management-state/cred/kubeconfig-system.yaml.
NVD description
In Rancher 1 and 2 through 2.2.3, unprivileged users (if allowed to deploy nodes) can gain admin access to the Rancher management plane because node driver options intentionally allow posting certain data to the cloud. The problem is that a user could choose to post a sensitive file such as /root/.kube/config or /var/lib/rancher/management-state/cred/kubeconfig-system.yaml.
More vulnerabilities in github.com/rancher/rancher
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free