In short
- CVE-2019-12303 is a HIGH (CVSS 8.8) vulnerability affecting github.com/rancher/rancher, rancher (suse).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.5% of all vulnerabilities.
- Fix: update to 2.2.4, 2.2.4+incompatible or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/rancher/rancher Go | ≥ 2.0.0, < 2.2.4≥ 2.0.0+incompatible, < 2.2.4+incompatible
| 2.2.42.2.4+incompatible
|
| rancher | ≥ 2.0.0, ≤ 2.2.3
| No fix yet |
Description
In Rancher 2 through 2.2.3, Project owners can inject additional fluentd configuration to read files or execute arbitrary commands inside the fluentd container.
NVD description
In Rancher 2 through 2.2.3, Project owners can inject additional fluentd configuration to read files or execute arbitrary commands inside the fluentd container.
More vulnerabilities in github.com/rancher/rancher
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free