In short
- CVE-2019-12422 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.shiro:shiro-core, shiro (apache).
- Chance of exploitation in the next 30 days (EPSS): 9.1%, higher than 95.3% of all vulnerabilities.
- Fix: update to 1.4.2 or later.
Description
Apache Shiro before 1.4.2, when using the default "remember me" configuration, cookies could be susceptible to a padding attack.
NVD description
Apache Shiro before 1.4.2, when using the default "remember me" configuration, cookies could be susceptible to a padding attack.
More vulnerabilities in org.apache.shiro:shiro-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free