In short
- CVE-2019-12760 is a LOW (CVSS 3.3) vulnerability affecting parso, parso (parso project).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 75.0% of all vulnerabilities.
- Fix: update to 0.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| parso PyPI | ≤ 0.4.0< 0.5.0
| 0.5.0
|
| parso | ≤ 0.4.0
| No fix yet |
Description
** DISPUTED ** A deserialization vulnerability exists in the way parso through 0.4.0 handles grammar parsing from the cache. Cache loading relies on pickle and, provided that an evil pickle can be written to a cache grammar file and that its parsing can be triggered, this flaw leads to Arbitrary Code Execution. NOTE: This is disputed because "the cache directory is not under control of the attacker in any common configuration."
NVD description
A deserialization vulnerability exists in the way parso through 0.4.0 handles grammar parsing from the cache. Cache loading relies on pickle and, provided that an evil pickle can be written to a cache grammar file and that its parsing can be triggered, this flaw leads to Arbitrary Code Execution. NOTE: This is disputed because "the cache directory is not under control of the attacker in any common configuration.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free