In short
- CVE-2019-12855 is a HIGH (CVSS 7.4) vulnerability affecting twisted, twisted (twisted).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.6% of all vulnerabilities.
- Fix: update to 19.7.0rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| twisted PyPI | < 19.7.0rc1
| 19.7.0rc1
|
| twisted | ≤ 19.2.1
| No fix yet |
Description
In words.protocols.jabber.xmlstream in Twisted through 19.2.1, XMPP support did not verify certificates when used with TLS, allowing an attacker to MITM connections.
NVD description
In words.protocols.jabber.xmlstream in Twisted through 19.2.1, XMPP support did not verify certificates when used with TLS, allowing an attacker to MITM connections.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free