| Package | Affected versions | Patched versions |
|---|---|---|
| traffix systems signaling delivery controller | ≥ 5.0.0, ≤ 5.1.0 | |
| libssh2 | < 1.9.0 | 1.9.0 |
| e-series santricity os controller | ≥ 11.0.0, ≤ 11.70.1 |
In libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free