In short
- CVE-2019-13126 is a HIGH (CVSS 7.5) vulnerability affecting github.com/nats-io/nats-server, github.com/nats-io/nats-server/v2, nats-server (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.2% of all vulnerabilities.
- Fix: update to 2.2.0, 2.0.2 or later.
Description
An integer overflow in NATS Server before 2.2.0 allows a remote attacker to crash the server by sending a crafted request.
Specific Go Packages Affected
github.com/nats-io/nats-server/v2/server
NVD description
An integer overflow in NATS Server before 2.0.2 allows a remote attacker to crash the server by sending a crafted request. If authentication is enabled, then the remote attacker must have first authenticated.
More vulnerabilities in github.com/nats-io/nats-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free