In short
- CVE-2019-13173 is a HIGH (CVSS 7.5) vulnerability affecting fstream (fstream project), fstream.
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.2% of all vulnerabilities.
- Fix: update to 1.0.12 or later.
| Package | Affected versions | Patched versions |
|---|
| fstream | < 1.0.12
| 1.0.12
|
| fstream npm | < 1.0.12
| 1.0.12
|
Description
Versions of fstream prior to 1.0.12 are vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system and a file that matches the hardlink will overwrite the system's file with the contents of the extracted file. The fstream.DirWriter() function is vulnerable.
Recommendation
Upgrade to version 1.0.12 or later.
NVD description
fstream before 1.0.12 is vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system, and a file that matches the hardlink, will overwrite the system's file with the contents of the extracted file. The fstream.DirWriter() function is vulnerable.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free