In short
- CVE-2019-13209 is a MEDIUM (CVSS 6.1) vulnerability affecting github.com/rancher/rancher, rancher (suse).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.7% of all vulnerabilities.
- Fix: update to 2.0.16, 2.1.11, 2.2.5, 2.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/rancher/rancher Go | ≥ 2.0.0, < 2.0.16≥ 2.1.0, < 2.1.11≥ 2.2.0, < 2.2.5< 2.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible
| 2.0.162.1.112.2.52.2.5-rc6.0.20190621200032-0ddffe484adc+incompatible
|
| rancher | ≥ 2.0.0, ≤ 2.2.4
| No fix yet |
Description
Rancher 2 through 2.2.4 is vulnerable to a Cross-Site Websocket Hijacking attack that allows an exploiter to gain access to clusters managed by Rancher. The attack requires a victim to be logged into a Rancher server, and then to access a third-party site hosted by the exploiter. Once that is accomplished, the exploiter is able to execute commands against the cluster's Kubernetes API with the permissions and identity of the victim.
NVD description
Rancher 2 through 2.2.4 is vulnerable to a Cross-Site Websocket Hijacking attack that allows an exploiter to gain access to clusters managed by Rancher. The attack requires a victim to be logged into a Rancher server, and then to access a third-party site hosted by the exploiter. Once that is accomplished, the exploiter is able to execute commands against the cluster's Kubernetes API with the permissions and identity of the victim.
More vulnerabilities in github.com/rancher/rancher
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free