In short
- CVE-2019-13647 is a MEDIUM (CVSS 5.4) vulnerability affecting grumpydictator/firefly-iii, firefly iii (firefly-iii).
- Chance of exploitation in the next 30 days (EPSS): 0.76%, higher than 55.4% of all vulnerabilities.
- Fix: update to 4.7.17.3 or later.
Description
Firefly III before 4.7.17.3 is vulnerable to stored XSS due to lack of filtration of user-supplied data in image file content. The JavaScript code is executed during attachments/view/$file_id$ attachment viewing.
NVD description
Firefly III before 4.7.17.3 is vulnerable to stored XSS due to lack of filtration of user-supplied data in image file content. The JavaScript code is executed during attachments/view/$file_id$ attachment viewing. NOTE: It is asserted that an attacker must have the same access rights as the user in order to be able to execute the vulnerability
More vulnerabilities in grumpydictator/firefly-iii
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free