In short
- CVE-2019-13970 is a MEDIUM (CVSS 6.1) vulnerability affecting antsword (antsword project), antsword.
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.5% of all vulnerabilities.
- Fix: update to 2.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| antsword | < 2.1.0
| 2.1.0
|
| antsword npm | < 2.1.0
| 2.1.0
|
Description
In antSword before 2.1.0, self-XSS in the database configuration leads to code execution via modules/database/asp/index.js, modules/database/custom/index.js, modules/database/index.js, or modules/database/php/index.js.
NVD description
In antSword before 2.1.0, self-XSS in the database configuration leads to code execution via modules/database/asp/index.js, modules/database/custom/index.js, modules/database/index.js, or modules/database/php/index.js.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free