In short
- CVE-2019-14751 is a HIGH (CVSS 7.5) vulnerability affecting nltk, nltk (nltk).
- Chance of exploitation in the next 30 days (EPSS): 5.7%, higher than 93.0% of all vulnerabilities.
- Fix: update to 3.4.5 or later.
| Package | Affected versions | Patched versions |
|---|
| nltk PyPI | < 3.4.5
| 3.4.5
|
| nltk | < 3.4.5
| 3.4.5
|
Description
NLTK Downloader before 3.4.5 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in an NLTK package (ZIP archive) that is mishandled during extraction.
NVD description
NLTK Downloader before 3.4.5 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in an NLTK package (ZIP archive) that is mishandled during extraction.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free