In short
- CVE-2019-14806 is a HIGH (CVSS 7.5) vulnerability affecting werkzeug, werkzeug (palletsprojects).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.8% of all vulnerabilities.
- Fix: update to 0.15.3 or later.
| Package | Affected versions | Patched versions |
|---|
| werkzeug PyPI | < 0.15.3
| 0.15.3
|
| werkzeug | < 0.15.3
| 0.15.3
|
Description
Pallets Werkzeug before 0.15.3, when used with Docker, has insufficient debugger PIN randomness because Docker containers share the same machine id.
NVD description
Pallets Werkzeug before 0.15.3, when used with Docker, has insufficient debugger PIN randomness because Docker containers share the same machine id.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free