In short
- CVE-2019-14853 is a HIGH (CVSS 7.5) vulnerability affecting ecdsa, python-ecdsa (python-ecdsa project).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.1% of all vulnerabilities.
- Fix: update to 0.13.3 or later.
| Package | Affected versions | Patched versions |
|---|
| ecdsa PyPI | < 0.13.3
| 0.13.3
|
| python-ecdsa | < 0.13.3
| 0.13.3
|
Description
Duplicate Advisory
This advisory has been withdrawn because it is a duplicate of GHSA-pwfw-mgfj-7g3g. This link is maintained to preserve external references.
NVD description
An error-handling flaw was found in python-ecdsa before version 0.13.3. During signature decoding, malformed DER signatures could raise unexpected exceptions (or no exceptions at all), which could lead to a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free