In short
- CVE-2019-14879 is a MEDIUM (CVSS 5.4) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.71%, higher than 53.6% of all vulnerabilities.
- Fix: update to 3.5.9, 3.6.7, 3.7.3 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.5.0, < 3.5.9≥ 3.6.0, < 3.6.7≥ 3.7.0, < 3.7.3
| 3.5.93.6.73.7.3
|
| moodle | ≥ 3.5.0, ≤ 3.5.8≥ 3.6.0, ≤ 3.6.6≥ 3.7.0, ≤ 3.7.2
| No fix yet |
Description
A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).
NVD description
A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free