In short
- CVE-2019-14993 is a HIGH (CVSS 7.5) vulnerability affecting istio.io/istio, istio (istio).
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.1% of all vulnerabilities.
- Fix: update to 1.2.4, 1.1.13 or later.
| Package | Affected versions | Patched versions |
|---|
| istio.io/istio Go | ≥ 1.2.0, < 1.2.4< 1.1.13
| 1.2.41.1.13
|
| istio | ≥ 1.2.0, < 1.2.4< 1.1.13
| 1.2.41.1.13
|
Description
Istio before 1.1.13 and 1.2.x before 1.2.4 mishandles regular expressions for long URIs, leading to a denial of service during use of the JWT, VirtualService, HTTPAPISpecBinding, or QuotaSpecBinding API.
NVD description
Istio before 1.1.13 and 1.2.x before 1.2.4 mishandles regular expressions for long URIs, leading to a denial of service during use of the JWT, VirtualService, HTTPAPISpecBinding, or QuotaSpecBinding API.
More vulnerabilities in istio.io/istio
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free