In short
- CVE-2019-15587 is a MEDIUM (CVSS 5.4) vulnerability affecting loofah, loofah (loofah project).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.2% of all vulnerabilities.
- Fix: update to 2.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| loofah RubyGems | < 2.3.1
| 2.3.1
|
| loofah | ≤ 2.3.0
| No fix yet |
Description
In the Loofah gem for Ruby through v2.3.0, unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished.
NVD description
In the Loofah gem for Ruby through v2.3.0 unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free