In short
- CVE-2019-16370 is a MEDIUM (CVSS 5.9) vulnerability affecting org.gradle:gradle-core, gradle (gradle).
- Chance of exploitation in the next 30 days (EPSS): 0.89%, higher than 59.4% of all vulnerabilities.
- Fix: update to 6.0 or later.
Description
The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.
NVD description
The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.
More vulnerabilities in org.gradle:gradle-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free