In short
- CVE-2019-16564 is a MEDIUM (CVSS 5.4) vulnerability affecting com.paul8620.jenkins.plugins:pipeline-aggregator-view, pipeline aggregator view (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.69%, higher than 52.8% of all vulnerabilities.
- Fix: update to 1.9 or later.
Description
Jenkins Pipeline Aggregator View Plugin 1.8 and earlier does not escape information shown on its view, resulting in a stored XSS vulnerability exploitable by attackers able to affects view content such as job display name or pipeline stage names.
NVD description
Jenkins Pipeline Aggregator View Plugin 1.8 and earlier does not escape information shown on its view, resulting in a stored XSS vulnerability exploitable by attackers able to affects view content such as job display name or pipeline stage names.
More vulnerabilities in com.paul8620.jenkins.plugins:pipeline-aggregator-view
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free