In short
- CVE-2019-17426 is a CRITICAL (CVSS 9.1) vulnerability affecting mongoose (mongoosejs), mongoose.
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.2% of all vulnerabilities.
- Fix: update to 5.7.5, 4.13.21 or later.
| Package | Affected versions | Patched versions |
|---|
| mongoose | ≤ 5.7.4
| No fix yet |
| mongoose npm | ≥ 5.0.0, < 5.7.5< 4.13.21
| 5.7.54.13.21
|
Description
Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some applications) because any query object with a _bsontype attribute is ignored. For example, adding "_bsontype":"a" can sometimes interfere with a query filter. NOTE: this CVE is about Mongoose's failure to work around this _bsontype special case that exists in older versions of the bson parser (aka the mongodb/js-bson project).
NVD description
Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some applications) because any query object with a _bsontype attribute is ignored. For example, adding "_bsontype":"a" can sometimes interfere with a query filter. NOTE: this CVE is about Mongoose's failure to work around this _bsontype special case that exists in older versions of the bson parser (aka the mongodb/js-bson project).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free