In short
- CVE-2019-17640 is a CRITICAL (CVSS 9.8) vulnerability affecting io.vertx:vertx-web, vert.x (eclipse).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.8% of all vulnerabilities.
- Fix: update to 3.9.4 or later.
| Package | Affected versions | Patched versions |
|---|
| io.vertx:vertx-web Maven | ≥ 3.0.0, < 3.9.4
| 3.9.4
|
| vert.x | = 4.0.0≥ 3.4.0, ≤ 3.9.4
| No fix yet |
Description
In Eclipse Vert.x 3.4.x up to 3.9.4, 4.0.0-milestone1, 4.0.0-milestone2, 4.0.0-milestone3, 4.0.0-milestone4, 4.0.0-milestone5, 4.0.0.Beta1, 4.0.0.Beta2, and 4.0.0.Beta3, StaticHandler doesn't correctly processes back slashes on Windows Operating systems, allowing, escape the webroot folder to the current working directory.
NVD description
In Eclipse Vert.x 3.4.x up to 3.9.4, 4.0.0.milestone1, 4.0.0.milestone2, 4.0.0.milestone3, 4.0.0.milestone4, 4.0.0.milestone5, 4.0.0.Beta1, 4.0.0.Beta2, and 4.0.0.Beta3, StaticHandler doesn't correctly processes back slashes on Windows Operating systems, allowing, escape the webroot folder to the current working directory.
More vulnerabilities in io.vertx:vertx-web
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free