In short
- CVE-2019-18658 is a CRITICAL (CVSS 9.8) vulnerability affecting helm.sh/helm, helm (helm).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.8% of all vulnerabilities.
- Fix: update to 2.15.2, 2.15.2+incompatible or later.
| Package | Affected versions | Patched versions |
|---|
| helm.sh/helm Go | ≥ 2.0.0, < 2.15.2≥ 2.0.0+incompatible, < 2.15.2+incompatible
| 2.15.22.15.2+incompatible
|
| helm | ≥ 2.0.0, < 2.15.2
| 2.15.2
|
Description
In Helm 2.x before 2.15.2, commands that deal with loading a chart as a directory or packaging a chart provide an opportunity for a maliciously designed chart to include sensitive content such as /etc/passwd, or to execute a denial of service (DoS) via a special file such as /dev/urandom, via symlinks. No version of Tiller is known to be impacted. This is a client-only issue.
NVD description
In Helm 2.x before 2.15.2, commands that deal with loading a chart as a directory or packaging a chart provide an opportunity for a maliciously designed chart to include sensitive content such as /etc/passwd, or to execute a denial of service (DoS) via a special file such as /dev/urandom, via symlinks. No version of Tiller is known to be impacted. This is a client-only issue.
More vulnerabilities in helm.sh/helm
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free