In short
- CVE-2019-18857 is a HIGH (CVSS 7.5) vulnerability affecting enshrined/svg-sanitize, svg-sanitizer (svg-sanitizer project).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 64.1% of all vulnerabilities.
- Fix: update to 0.12.0 or later.
Description
enshrined/svg-sanitize before 0.12.0 mishandles script and data values in attributes, as demonstrated by unexpected whitespace such as in the javascript :alert substring.
NVD description
darylldoyle svg-sanitizer before 0.12.0 mishandles script and data values in attributes, as demonstrated by unexpected whitespace such as in the javascript	:alert substring.
More vulnerabilities in enshrined/svg-sanitize
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free