In short
- CVE-2019-18874 is a HIGH (CVSS 7.5) vulnerability affecting psutil, psutil (psutil project).
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.3% of all vulnerabilities.
- Fix: update to 5.6.6 or later.
| Package | Affected versions | Patched versions |
|---|
| psutil PyPI | < 5.6.6
| 5.6.6
|
| psutil | ≤ 5.6.5
| No fix yet |
Description
psutil (aka python-psutil) through 5.6.5 can have a double free. This occurs because of refcount mishandling within a while or for loop that converts system data into a Python object.
NVD description
psutil (aka python-psutil) through 5.6.5 can have a double free. This occurs because of refcount mishandling within a while or for loop that converts system data into a Python object.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free