In short
- CVE-2019-18886 is a MEDIUM (CVSS 5.3) vulnerability affecting symfony/security-http, symfony/symfony, symfony (sensiolabs).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.1% of all vulnerabilities.
- Fix: update to 4.2.12, 4.3.8 or later.
| Package | Affected versions | Patched versions |
|---|
| symfony/security-http Packagist | ≥ 4.1.0, < 4.2.12≥ 4.3.0, < 4.3.8
| 4.2.124.3.8
|
| symfony/symfony Packagist | ≥ 4.1.0, < 4.2.12≥ 4.3.0, < 4.3.8
| 4.2.124.3.8
|
| symfony | ≥ 4.2.0, ≤ 4.2.11≥ 4.3.0, ≤ 4.3.7
| No fix yet |
Description
An issue was discovered in Symfony 4.2.0 to 4.2.11 and 4.3.0 to 4.3.7. The ability to enumerate users was possible due to different handling depending on whether the user existed when making unauthorized attempts to use the switch users functionality. This is related to symfony/security.
NVD description
An issue was discovered in Symfony 4.2.0 to 4.2.11 and 4.3.0 to 4.3.7. The ability to enumerate users was possible due to different handling depending on whether the user existed when making unauthorized attempts to use the switch users functionality. This is related to symfony/security.
More vulnerabilities in symfony/security-http
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free